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18 Templates 

Excel features the option of saving workbooks as templates. A template is a type of form that 

can be used as a basis for creating new workbooks. Design elements, formulas, formats, or 

texts are saved in templates. You can use these in other workbooks based on this template. 

18.1 The benefits of a template 

You can open a sample template like any other workbook and make any changes you want. 

 
Templates are used to make your work easier and create consistency. When you open 

workbooks based on these workbook templates, you can keep the elements you need. 

You can use the basic layout, formats, and formulas and add the data you want. 

If you use the settings listed below regularly, you should save them in templates: 

 number of sheets in a workbook 

 formattings 

 page formats 

 print range settings 

 headers/footers 

 row and column labels 

 date 

 formulas 

 pictures and graphics 

 custom toolbars 

 macros 

 protected areas of the workbook. 

18.2 Creating a template 

Our task now is to create a template with pages that are printed in landscape format. The head-

er should contain the text Garden Accessories Meyer LLC and the date and the footer should 

include the page numbers. The workbook is designed to record the monthly sales statistics by 

branches and product categories. 

1. Open a new worksheet, e.g., with (Ctrl)+(N) or via File menu, New. 

2. On the Page Layout tab, in the Page Setup group, click . The dialog box appears. 

3. On the Page tab, select the  Landscape option. 

 

Page tab 
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Headers and footers 

1. On the Header/Footer tab, click the [Custom_Header] button. 

 

Header/Footer tab 

2. Click in the  Left section box. Type in the following text: Garden Accessories Meyer LLC. 

3. We now want the date to appear in the Right section box. So, click the Date 

icon: 
 

 

Custom header with the icons: 

 
The icons for custom headers and footers 

4. Click [_OK_] to close the Header dialog box. 

5. In the Header/Footer tab, now click the [Custom_Footer] button. 

6. Click in the Right section box and type in the following: 

a) Page + Space 

b) Click the Page Number  icon + Space 

Format Text

Number of Pages

Time

File Name

Insert Picture

Format Picture

Page Number Date Sheet Name

File Path + Name
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c) of + Space 

d) Click the Number of Pages  icon. 

Result: 

Page &[Page] of &[Pages] 

 

Custom footer 

7. Click [_OK_] to close the Footer dialog box. 

8. Now click [_OK_] to close the Page Setup dialog box. 

 

Tab with custom headers and footers 

Enter constant data 

The next step is to enter the fixed (constant) data in the template: 

1. For the purpose of this exercise, copy the data from the worksheet below into your work-

sheet: 
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Entered items 

2. Move the cell cursor to cell B9 and type in the following formula: 

=SUM(B5:B8) 

3. Then copy this formula and paste it into the range C9 to E9. 

4. Click in cell E5 and type in this formula: 

=SUM(B5:D5) 

5. This formula is also required in cells E6 to E8. Insert the formula into this range. 

 
As you haven't entered any numbers into your worksheet, a 0 appears in the cells that 

contain a sum formula. 

18.3 Saving the template 

Once you have completed the settings, you can save your template. 

 
1. Press the (F12) key, or open the File menu and click Save as. 

2. Type in the file name Garden Meyer. 

3. In the Save as type box, select the Excel template (*.xltx). If you want to save  

a template containing macros, select type (*.xltm)! 

 
Office templates are stored in the Custom Office Templates folder, a sub-folder of 

Documents: 
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Save As window 

4. Click [Save]. The sample template is saved with the file extension .xltx. 

5. Now, close the sample template to make it available as a template! 

18.4 Displaying custom templates on the File menu 

Your templates can be found in the file explorer, namely in the folder you saved them in. How-

ever, it is also possible to display the custom templates on the New page of the File menu. 

Here's how it works: 

1. Open Excel Options via the File menu und switch to the Save page. 

2. In the Default personal templates location text box, enter the complete path of your tem-

plate folder and click [_OK_]. As already mentioned, Excel uses the Custom Office Tem-

plates folder by default. In case of the user Amy, the path is 

C:\Users\Amy\Documents\Custom Office Templates 

If necessary, simply replace Amy with your user name. 

 

Entering the default location for personal templates 

On the New page of the File menu, below Suggested searches, two categories are now dis-

played: FEATURED with the default templates and PERSONAL with your custom templates. 

Clicking one of the categories opens the corresponding list. 

 
The settings in Excel Options have to be adjusted in each Office programm separate-

ly, if you want to display your custom templates on the New page. 
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18.5 Using the template for a new workbook 

As your template already contains format-

tings such as header/footer etc. you now 

only need to enter the data. If you want to 

use your sample template Garden Meyer 

as the basis for a new workbook, proceed 

as follows: 

1. Open the File menu and click New. 

2. On the New page, click PERSONAL. 

3. On the page with your custom tem-

plates, click Garden Meyer. 

A workbook opens which contains all the 

entries and settings of the Garden Meyer 

template.  

 

File menu, New 
 

 
a) In the title bar, you'll see GardenMeyer1 instead of the standard Sheet1. 

b) If you want to save a preview, open the sample template Garden Meyer.xltx again. 

Select between one of the two options below: 

 Open the File menu and click Save As an Browse. In the Save As window, ac-

tivate the  Save Thumbnail check box at the bottom on the left. 

 Alternatively, call up: File menu, Info, Properties, Advanced Properties, 

Summary tab. Activate the check box  as displayed in the picture below. Then 

save and close the sample template. 

 

Save thumbnail 
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18.6 Changing the template 

You can edit templates just like any other document: 

1. Call up the Open page of the File menu, click Browse, and select the Templates (*.xltx; 
*.xltm; *.xlt) file type. 

2. Select and open the relevant file. 

3. Make the required changes. 

4. Save the template file. 

5. The template is now available in the modified form on the New page of the File menu, in the 
PERSONAL category. 

18.7 Exercise 

Create the sample template according to the illustration below: 

 

Entered items 

The relevant formulas should be entered in the following cells: 

B6 =SUM(B7:B11) 

B12 =SUM(B13:B14) 

B15 =B6+B12 

C6 =SUM(C7:C11) 

C12 =SUM(C13:C14) 

C15 =C6+C12 

You can calculate the deviations as the difference between the current month and the previous 

month. Enter the relevant formulas for this as well. 

Save the template as Monthly Accounting.xltx. 
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19 Forms 

19.1 Validation and cell protection 

Simple forms can be set up with protected cells and data validation. You can use these func-

tions to ensure that users may only type in permitted cells. You can also create notes or drop-

down lists. You must perform the data validation before the cell protection as Excel will not allow 

new validation criteria in a protected sheet. The subject was already discussed on page 30. First 

create the following sheet: 

 

Cut-out 

Validation 

Use the data validation function to restrict data entry in a cell. For example, you may want to 

restrict data entry to dates or numbers, limit choices by using a list of predefined terms, or make 

sure that only a certain range of numbers are entered. The validation function can be – but does 

not have to be – combined with cell protection. 

1. Copy the data from the previous image into a new, blank workbook or open the file 
Forms.xlsx with the Application for leave sheet. 

2. Select the cell you want to validate. In this case B4. 

3. On the Data tab, in the Data Tools group, click the Data Validation button (see also page 

51). 

4. On the Settings tab, select which type of entries you want to allow: 

 

Selecting validation criteria 

For numbers, data, and time, you can specify a minimum and a maximum value or, respectively, 

a start and end date. 

On the Input Message tab, you can enter a text that is shown when the cell is selected. 
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Saving an input message (cut-out) 

You can also set up an Error Alert. Select 

the type: 

 A Stop alert prevents invalid data en-
tries in this cell. 

 A Warning alert warns users of an 
invalid entry. Users can still accept data 
by clicking [Yes]. 

 With an Information alert, every entry 
can be typed into the cell, users only 
have to accept the alert with [_OK_].  

Error alert when invalid data is entered 
 

The input message is displayed if you hover 

the mouse pointer over the cell. If someone 

now enters invalid data into this cell, the error 

alert appears. 

 

Input message display 
 

Drop-down lists can be created using a list: 

1. Select List from the validation criteria 

box. 

2. In the right-hand check box, activate 

the  In-cell dropdown option. 

3. In the Source box, enter the items that 

you want to be displayed in the drop-

down list. The list entries are separated 

by commas. 
 

Data validation settings 
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You can also create the list entries by refer-

ring to a range of cells elsewhere in the work-

book. For example, cells M1 to M9 can con-

tain the department names: 

Click in the input box under Source and then 

select the cells M1:M9 in the worksheet. The 

list entries are then inserted from this range.  

Entering a cell range as source 
 

A drop-down arrow is inserted next to the cell. 

Click the arrow to open the list. 

 

Drop-down list 

Cell protection 

In this example, the users are only allowed to enter the last name and first name in cells B2 and 

D2, the start date and end date in B4 and D4, and the department in B6. All other cells must be 

protected from invalid data entry. 

1. First select the cells that you want to keep editable (multiple selection using the (Ctrl) key): 

 

Selecting cells 

2. In the context menu, select the Format Cells command and click the Protection tab. 

3. Deactivate the  Locked check box: 

 

Protection tab (pane) 

4. Click [_OK_] to close the dialog box above. 

5. Then click the Review tab on the ribbon at the top and in the Changes 

group, select the Protect Sheet button.  

6. The following check box must be activated in the options list: 

http://www.dettmer-verlag.de/


 Schulungsunterlage für Excel 2016 Weiterführung Englisch  

 174 Musterseite aus dem Dettmer-Verlag, D-76889 Kapellen 

www.dettmer-verlag.de 

 Select unlocked cells. 

If you deactivate the Select locked cells box, users will 

only be able to edit the cells that you unlocked in the 

previous step. 

A user can shift between unlocked cells in a protected 

worksheet using the (Tab_) key. 

You can also specify a password to be entered in order 

to unprotect the sheet. Protection is active even without 

a password. If you do not supply a password, then any 

user can unprotect the sheet.  

Selecting unlocked cells 

19.2 Controls 

First make sure that the Developer tab is activated on the ribbon as 

described on page 139. 

In the Control toolbox, you can find all the tools you need to create 

forms. You can open this function on the Developer tab, in the Con-

trols group, via the Insert button. It is only active if the sheet protec-

tion has been deactivated or you are working on another worksheet. 

Therefore, switch to the Controls sheet. 

As soon as you use one of the controls, Excel changes to design 

mode. In design mode, you can edit controls but they are not active. 

To test the effect of the control, you have to exit design mode. 

 

Developer tab,  
Controls group 

 

Form controls +  
ActiveX controls 

General 

All controls have common properties (appearance, behavior, presettings). Objects can be hid-

den when printed and the forecolor and backcolor or borders can be set. 

1. Select the check box control  from the ActiveX Controls(!) section and insert it on the 

worksheet. Design mode is activated automatically, you'll recognize this by the selection 

rectangle around the control. 

 

Check box with number 

2. Keep the control selected. Click the Properties icon. A new 

window opens. 

 

Design Mode icon 

 

Properties icon 
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3. The Caption property is used to label the control. 

4. Controls that you don't want to print in a document 

receive the PrintObject = False property. These 

controls are displayed in the worksheet but are not 

printed. 

5. You can change the appearance of controls using 

the various color or style properties: 

For example, BackColor or ForeColor are respon-

sible for background color and font color. 

To specify the font and size, click the Font line. In 

the active line, a  button appears on the right. Use 

this button to open the Font dialog box. 

 

Set properties 

Text boxes 

The simplest of all controls is a text box. Users can enter text into boxes which can then be 

moved to another position in the worksheet. 

1. Insert a text box  (ActiveX controls). 

2. Text that you enter in the text box must be bound to a cell so that it can be used freely in 

the worksheet. This is possible using a LinkedCell. 

3. Select the Properties of the text box and enter the 

output cell under LinkedCell. 

4. If you want to enter a predefined value for the text box, 

enter it under the Value property. This value is dis-

played in the text box until users overtype it with their 

own text. 

5. With the MultiLine property, you can specify whether 

a control accepts multiple lines of text or not: 

True means text is displayed across multiple lines 

False means it is displayed single-line. 

6. If MultiLine is set to True, the user can start a new 

line in the text box using (Ctrl)+(_Enter_). The text is 

displayed across multiple lines. 
 

Selecting text box properties 

Check boxes and option buttons 

Check boxes 

Use check boxes to provide the user with several options. It is possible to select multiple check 

boxes at the same time. 

1. Click the Check Box icon  (ActiveX controls). 

2. Plot the check box. The label is set to default as Check box with a consecutive number: 
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Check box with sequence number 

3. Open the Properties for the check box. Click in the 

box next to the Caption property and change the 

name to Hotel brochure. 

4. In the Properties window, you must also specify in 

which cell you want to enter the output value for the 

check box. Every selected check box returns the 

TRUE value, cleared boxes return FALSE. Enter a 

cell under LinkedCell for every single check box. 

You can only enter the output cell. You cannot select 

the cell from the sheet by mouseclick. 

 

Selecting the check box properties 

5. Whether a check box is active or not at the beginning is specified in the Value property. 

FALSE indicates that the check box is cleared. TRUE selects it: A check mark appears in 

the box. 

6. Draw more check boxes: Directions, List of restaurants, Company brochure, Program, and 
Exhibition plan. 

You must first exit design mode before you can test the check box: 

1. Deactivate design mode by clicking the icon. 

2. Then, select and clear the check boxes. The TRUE and FALSE values 

are typed into the output cells. 

 

Design Mode 
button 

 

Selecting or clearing the check boxes 

 

Results in the output cells 

3. Save the file as macro-enabled workbook (.xlsm) with the name Forms and switch back to 

design mode to further edit the form. 

Option buttons 

In contrast to check boxes, an option button (or radio button) only allows a single choice from a 

group of mutually exclusive choices. Option buttons bound to different groups must be given a 

different group name: 

1. Click the Option Button icon  (ActiveX controls). 

2. Plot an option button with label. 
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3. As with the check box, change the option button 

label in the Caption property. 

4. A group name must be given to all option boxes in 

the same group. Enter the name under Group-

Name. 

5. Specify the output cells for the option buttons in the 

LinkedCell property. 

6. The selected option button returns the value TRUE 

all others return FALSE. 

7. From all the option buttons that are bound by a 

group name, only one can be selected. Only one 

single TRUE value is permitted. 

8. Add the option buttons Company, Authority, Associ-

ation, and Private person with the same group 

name. 

 

Selecting the option button properties 

 

Selecting an option 

 

Results in the output cells 

Toggle button 

The toggle button is a special feature in Excel that is similar to an option button or a check box 

as it alternates between an enabled and disabled state. A toggle button can return the value 

TRUE or FALSE: 

1. Plot a Toggle Button  (ActiveX controls). 

2. Assign a label in the Caption property. 

3. In the LinkedCell property, enter the cell to which 

you want to link the active value. 

4. If the button is not pressed, the error value FALSE is 

returned. 

 

5. If the button is pressed, TRUE is returned. 

 

 

Selecting the toggle button properties 

Analyzing TRUE and FALSE 

The check boxes, option buttons, and toggle buttons all return the values TRUE or FALSE. Both 

these words are typed into output cells and are interpreted by Excel as error values and not text. 

They can be retrieved using the functions TRUE() or FALSE(). 
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In this example, Excel is queried whether 

the logical value TRUE appears in cell J4. 

If it appears, an X is entered in cell K4, if 

not, the cell remains blank. 
 

Error value query 

Note that TRUE or FALSE are not inter-

preted as text but as the logical functions 

TRUE() or FALSE()! 

=IF(J4=TRUE(),"X","") 

or 

=IF(J4=FALSE(),"","X") 

List and combo boxes 

Drop-down lists can be inserted as list boxes or as 

combo boxes. Both boxes have the same function 

but slightly different controls: 

 List boxes display a box with several lines. If 
the display size of the box is not large enough, 
you can scroll using a scroll bar. 

 Combo boxes usually appear as a single line 
and offer a drop-down list to select from. 

1. Plot a List Box (ActiveX controls)  or a 

Combo box  (ActiveX controls). 

2. In the Properties task pane, under 

LinkedCell, enter the cell reference that con-

tains the list box selection. The linked cell re-

turns the number of the selected item in the 

list box. 

3. List boxes and combo boxes are filled with 

items from a cell range. Enter the range under 

ListFillRange. Here, it is K23:K30. 

 

Selecting properties of lists 
 or combo boxes 

 
The combo box displays the places in the 

same order as they are entered in the 

ListFillRange property box. 

The output cell is I23: As soon as a city is 

selected in the combo box, the name of 

the city appears in cell I23. 

Don't forget to save the workbook every 

now and then! 
 

Combo box – output cell I23 

Scroll bars and spin buttons 

Use spin buttons and scroll bars to insert consecutive numbers. Both return a digit: 
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1. Plot a Spin Button  (ActiveX controls) or a Scroll 

bar  (ActiveX controls). 

2. In the Properties window, under LinkedCell, enter the 

output cell. 

3. Specify the highest and lowest value in the Max and 

Min properties. 

4. The value you enter in SmallChange specifies the step 

size of the counting. 

If 5 is entered, the spin button moves in increments of 5. 

 

Spin button 

 

Selecting spin button properties 

Command buttons 

You can run macros using a command button. You will need a VBA code which you record or 

enter in the VBA Editor: 

1. Plot a Command Button  (ActiveX controls). 

2. Click the View Code button. 

 

View Code icon 

3. The VBA editor opens with a blank sheet. Select the CommandButton1 entry from the list 

box  instead of General. Here, only the start and the end of a macro are displayed. 

 

Start and end of a macro 

The name of the command button (CommandButton1) is important as it must be identical 

to the caption from the button properties. 

4. Enter the macro code you want between Private Sub and End Sub. 

The row below prints the active sheet twice: 

Private Sub CommandButton1_Click() 

 ActiveWindow.SelectedSheets.PrintOut Copies:=2 

End Sub 

5. Save  the code, close the VBA editor, and change the caption of the button via the 

Properties window to Print 2x. 

19.3 Formatting 

View 

Forms should be presented as clearly as possible. Certain elements can be superfluous, e.g., 

gridlines and column headers, and can be removed: 

1. Hide the gridlines for the screen presentation via the Show group on the View tab: 
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Window options 

2. Here, you can hide row and column headings, as well 

as the formula bar. Excel then hides the column head-

ers (A to IV) and the row numbers. 

3. It may also be useful to hide the sheet tab (Sheet1, 

page Seite 27): Right-click the respective sheet tab and 

select Hide from the context menu. This is particularly 

recommended, if you want the user to make entries on 

one sheet only. To show it again, right-click one of the 

the remaining sheet tabs and select Unhide.  

Sheet tab context menu 

Hide and unhide columns and rows 

Many controls return error values that confuse the user. Hide 

the columns: 

1. Select the columns you want to hide. Make sure you 

select entire columns via the column headers. 

2. Right-click the selected range and select the Hide 

command from the context menu. 

3. The missing letters on the column headers indicate 

which columns are hidden: 

 

Column K was hidden 

 

Hiding selected columns 

4. To show the hidden columns again, select the columns that are still visible (in this example 

J and L). Right-click in the selected columns and select the Unhide command. 

19.4 Printout 

When working in forms, it can sometimes be useful to enforce fitting the printout to one page. 

This ensures that you can specify how many pages you want to print regardless of the connect-

ed printer. Use the same dialog box to set headers and footers with page numbers and file 

names. 

1. To open the dialog box below, on the Page Layout tab, in the Page Setup group, click . 

2. On the Page tab, enter: 

 Fit To: 1 page(s) wide by 1 tall. 

 

Fitting the form page (cut-out) 
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With forms across multiple pages, you can also set up the number of pages and the 

height and width you want the form to have (e.g., 1 page wide by 2 pages tall). 

Use the Header/Footer tab to customize headers or footers via the Custom Headers and Cus-

tom Footers buttons (see page 165): 

 
The icons for custom headers and footers 

Excel features two icons for the page numbers: 

 The first icon  indicates the active page number of the sheet. 

 The second icon  shows the entire number of pages. 

You can call up the file name with or without path, and the sheet name with these three icons: 

 File name including path  

 File name  

 Sheet name . 

If some columns are reserved for evaluation or specific cell ranges are filled with list boxes, 

these will also be printed on the sheet. You can avoid this by setting a print area: 

1. In the Page Setup dialog box, open the Sheet tab. 

2. In the Print Area field, enter the cell range that you want to print: 

 

Entering the print area 

3. The print area is identified on the worksheet with a black dash 

line. 

4. To clear the print area, select the command displayed on the 

right on the Page Layout tab in the Page Setup group.  

Clearing the print area 

19.5 Exercise: scroll bar 

In the following exercise, the task is to use the Scroll bar control to select consecutive 

numbers as described on page 178. 

1. Open the Car Suspension.xlsx workbook from page 116, and save it with the 

new name Car Suspension with Scroll Bar 

2. Select the complete line chart on the Chart1 sheet by clicking it and copy it to the 

clipboard. 

3. On the Oscillations sheet, click cell A40 and paste the copied chart here.  
 

Format Text

Number of Pages

Time

File Name

Insert Picture

Format Picture

Page Number Date Sheet Name

File Path + Name
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4. Make the chart slightly smaller and plot the  Scroll 

Bar (ActiveX control) as you can see in the following 

image Line Chart with Scroll Bar. 

5. We now want to use this scroll bar to conveniently 

change a parameter from range F6 to F9. The Oscilla-

tion Period in F9 is suitable. In design mode, enter 

the cell reference F9 under LinkedCell in the Proper-

ties window (page 174). 

6. In the Max and Min properties, enter the highest value 

of 40 and the lowest value of 1. 

7. Enter the increment 1 under SmallChange. Then exit 

the design mode. 

8. It is not necessary, but it is interesting to see what 

happens when you enter the current value next to the 

scroll bar: Enter a link to the cells E9 (=E9) and F9 

(=F9) as you can see in the chart below in cells H50 

and H51: 

 

Properties 

 

Line chart with scroll bar 

9. To change the oscillation period and the line chart, hold down the left mouse button and 

drag the slider in the new scroll bar. 
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