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16 Tables of Contents and Indexes 

16.1 Table of contents 

By default, Word creates a table of contents for the 

headings based on the predefined or modified style 

sheets. But you may create a table of contents from 
any style sheet. 

How to create a table of contents 

1. Position the cursor at the place in the 

document, at which the table of contents is to 

be inserted, mostly at the begin of the 

document. 

2. On the References tab, Table of Contents 

group, click the Table of Contents button. The 

gallery shown on the right-hand side is 

opened. 

3. From the gallery, select one of the three 

predefined tables of contents. But only 
Automatic Table 1 and Automatic Table 2 

refer to style sheets. Moreover, a numbering is 

only shown, when the heading styles are 

numbered (also refer to page 149). 

4. If you want to design your own table of 
contents, click the Insert Table of Contents 

command at the bottom of the gallery. The 

following dialog box appears: 

 

Table of contents gallery 

 

Table of Contents tab page 

5. From the list box, select a Format. 

6. To customize the index style sheets, click the [Modify] button. The 

following dialog box appears:  

Formats 
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Modify styles 

7. When you want to include, in addition to the Heading 1 through Heading n style sheets, 

more style sheets into the table of contents or to delete style sheets from the table of 
contents, click [Options] in the Table of Contents dialog box. The following dialog box is 

displayed: 

 

Options for table of contents 

8. Select the style sheets that should appear in the table of contents, and enter the 
corresponding level, with level 1 assigned to the TOC 1 style sheet, level 2 assigned to the 

TOC 2 style sheet, etc. 

9. Click [_OK_] to confirm your entries. Word returns to the Table of Contents dialog box. 

10. Also click [_OK_]  here. If a table of contents already exists, Word asks to replace it. 

Update the table of contents 

 Place the cursor in the table of contents. In the 

field view, place the cursor in the field ({ TOC \l }). 

Now press the (F9) key. The dialog box shown on 

the right-hand side appears. Choose an  option 

and click [_OK_]. 

 

Open this dialog box 
by pressing (F9) 

 Or open the Table of Contents dialog box again, as described above. After having made 

the desired modifications, click [_OK_]. Depending on the cursor position before opening 

this dialog box, the options appearing in the following dialog box may differ: 
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- The cursor is in the table of contents: 

[_OK_]: The existing table of contents will be 

updated. 

[Cancel]: Abort, the table of contents will not be 
updated. 

- The cursor is not in the table of contents: 

[_Yes_]: The existing table of contents will be 
updated. 

[_No_]: A new, additional table of contents is 

created at the cursor position. The existing table 
of contents will not be updated. 

[Cancel]: Abort, the table of contents will not be 
updated. 

 

The cursor is in the table of contents 

 

The cursor is not in the table of contents 

16.2 Index 

Creating an index requires index entries to be placed at the respective positions within the text. 
An example of an index is given at the end of this document. 

Marking index entries 

Word provides the following options for creating an index: 

 mark main entries 

 mark sub entries 

 mark cross-references 

 format entries 

 define page ranges (e.g. outline 40-45). 

How to create an index entry 

1. Select the word or the text area that is intended to be 

an index entry. If the word is not included in the text, 

place the cursor at the position, at which the index 

entry is to be inserted. 

 

Mark an index entry 

2. Click the Mark Entry button on the 

References tab, Index group. The dialog 

box shown on the right-hand side is 

opened. When you have selected a word, 
it will appear in Main entry. 

 

3. Accept or modify the word in the Main entry line. 

You may also enter a Subentry. 

4. Click [Mark] to create the index entry. The dialog box 

remains open, so that you may mark additional index 

entries. 
 

 
Index entries are formatted hidden. Hidden text is only visible, when the Show 

All button on the menu ribbon Home tab, Paragraph group, is enabled: 

 

Hidden text is underlined by a dotted line. 

 

Creating index entries using a field code 

The XE field code provides another option for creating index entries: 

{ XE ”Main entry:Subentry” \t ”Cross-reference” }. 
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The \t and ”Cross-reference” may be omitted. How to create index entries using the XE 

(Index) field code: 

1. To enter the hidden text, use the mouse to select . 

2. Place the cursor at the position, at which you want to insert the index entry. 

3. Press (Ctrl)+(F9). A blank field {  } is shown. 

4. Enter the XE field name into this empty field first and then the main and, if necessary, the 

sub entry, enclosed by quotes. Main antries and subentries are separated by a colon 
(without space!), e.g.: 

{ XE ”Form letters” } or { XE ”Form letters:Data source” }. 

5. Select the entire field and copy it to the clipboard. 

6. Place the cursor at the next position, at which an index entry should appear. 

7. Insert the field from the clipboard and modify only the main entry and/or subentry within the 

quotes. 

8. Repeat steps 5 and 6 for additional index entries. 

Modifying index entries 

To modify index entries, you have to make the hidden text visible at first (Show All 

button). Then you may modify the entry in the XE field code as desired.  

Creating and updating an index 

1. Position the cursor at the place, where you want to insert the index (typically at the end of 

the document). 

2. Click the Insert Index button on the References tab, Index group. The following 

dialog box is opened:  

 

Insert Index 
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3. Enter the following: 

  Indented option, when the subentry should appear below the main entry. 

  Run-in option, when the subentry should appear next to the main entry. 

 Enter the desired number of columns or keep the default setting 2. 

 Select an entry from the Formats list box. In the Print Preview 
frame, you see an example index for the current format. 

 When you want to  Right align page numbers, enable the 

respective check box. Then you may also select a Tab 

leader... for the tab stop gaps, as shown in the following 

example. 

 

Formats 

4. Click [_OK_] to confirm your entries. If an index already exists, Word asks to update it. 

 

Index example 

If only the field code is visible instead of the index (e.g. { INDEX  \e ”  ” \a  \c  ”2” } ), you may 
show the index using the (Alt)+(F9) shortcut. 

Updating index 

After having made the view entries, place the cursor in the index. Depending on the settings in 
the options, the index may be shown including a light gray background color. In the Options, 

you may use the Advanced page in the Show document content pane to set the Field 
shading. Use the (F9) key to update the index. 

Editing index styles 

Each paragraph in the index is certainly based on a style sheet: Index Heading for the letters of 

the alphabet, Index 1 for the main entries, and Index 2 for the sub entries. If you want to modify 

these style sheets, it may happen that the styles are not shown in the Styles task pane. (open 
task pane: On the Home tab, Styles group, click this small  button.) 

In this case, click the Manage Styles button at the bottom of the task pane. The 

following dialog box is opened:  
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On the Edit tab, select the respective 
style sheet and click [Modify] 

To show a hidden style sheet in the 

task pane, click [Show] on the 
Recommend tab page. 

 

Modify the selected style 

16.3 Table of figures 

You may create tables of figures, lists of tables, or any other indexes. You are required to 
assign a separate style sheet to each type of index. 

Your task 

You have created a document containing multiple pages and a lot of illustrations and tables and 

want to add a list of tables and figures at the beginning of the document, following the table of 

contents. 

1. At first, define two style sheets: the Table caption style sheet for labeling the tables and 

the Figure caption style sheet for the illustrations. 

2. If a table appears in the document, label it e.g. as follows 

Table 1: Shortcuts for paragraph formatting 

and assign the Table caption style sheet to this paragraph. 

Label an illustration e.g. as follows 

Figure 1: Dialog box Character 

and assign the Figure caption style sheet to this paragraph. 

After assigning the style sheets, you may now create a table of figures for the tables and 

illustrations. 

3. Place the cursor at the position within the document, at which the list of tables should 

appear. 

4. Click the Insert Table of Figures button on the References tab, Captions group. 

The following dialog box is opened:  

http://www.dettmer-verlag.de/


Seminarunterlage Word 2016 Weiterführung Englisch 

   162 Musterseite aus dem Dettmer-Verlag, D-76889 Kapellen 

www.dettmer-verlag.de 

 

Create a Table of Figures 

5. Click [Options]. The dialog box shown on the 

right-hand side is displayed. 

6. Enable the  Style check box and select the 

Caption style sheet. 

7. Click [_OK_]. The Table of Figures Options 

dialog box will be closed. 

 

Options for table of figures 

8. When you click [_OK_] also in the Table of Figures Options dialog box, the table of figures 

for the table labels will be created. 

The list of tables might have the following appearance: 

Table 1: Shortcuts for paragraph formatting .......................................................................................... 3 

Table 2: Shortcuts for character formatting part 1  ................................................................................ 9 

Table 3: Shortcuts for character formatting part 2 ............................................................................... 13 

Table 4: Shortcuts for highlighting text ................................................................................................. 21 

Table 5: Shortcuts for cursor positioning .............................................................................................. 33 

Example for a list of tables 

To create a table of figures, you may use a similar procedure as used for creating the list of 

tables. However, you need to assign the Figure caption style sheet. Please make sure that the 
cursor is not in an existing index! 

After clicking [_OK_] in the Table of Figures dialog box, the following question appears. Click 

[_No_] to create another table of figures. When you click [_Yes_], the list of tables will be 

replaced! 

 

Replace table of figures? No! 

Creating a table of figures with the aid of captions 

1. Select the item and click the Insert Caption button in the Captions group of 

the References tab. The Caption dialog box opens.  
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2. The caption for the item has already been entered automatically (e.g. Figure 1). Add the 

explanatory text that you want to be displayed in your document, for example: 

 

Adding a caption 

3. In the Label drop-down box  select the item type, e.g. Figure or Table. If the desired type 

does not exist, you can use the [New_Label] button to create a new type, which will then be 

selectable in the drop-down list. 

 
If you want to gather different item types, like images and tables, in the same table of 

figures, it is recommended that you choose the same label for the relevant items, e.g. 

figure. 
 
4. Use the Position  drop-down box to determine 

whether the caption is to be displayed above or below 

the item. 

5. With the [Numbering] button you can choose a different 

numbering format where necessary. 

6. With a click on [_OK_] the caption is assigned to the 

item and you can create the table of figures.  

7. Place the cursor in the document where you want the 

table to appear, and click the Insert Table of Figures 

button on the References tab in the Captions group. 

8. In the Table of Figures dialog box from page 162  click 

[Options]. 

9. Activate the  Style check box, select the Caption 

style and click [_OK_]. The Table of Figures Options 

dialog box is closed. 

10. Once you click [_OK_] in the open Table of Figures 

dialog box as well, the table of figures is created. 

 

Changing the numbering format 

 

Options 

16.4 Cross-reference 

A cross-reference is used to point to another position within your document, e.g. to a page 

number. You may use the following items: 

 numbered items 

 headings 

 bookmarks 

 footnotes 

 endnotes 

 equations 

 figures, or 

 tables. 
 

Reference types 

Bookmarks can be placed at any position and serve as a kind of hidden, invisible marker to 

which you can switch at any time via the following dialog box. In addition, bookmarks can be 

http://www.dettmer-verlag.de/


Seminarunterlage Word 2016 Weiterführung Englisch 

   164 Musterseite aus dem Dettmer-Verlag, D-76889 Kapellen 

www.dettmer-verlag.de 

used in the context of cross-references, for example to refer to their contents or to the page on 
which the bookmark is found. 

To create a bookmark, 

1. place the cursor at the position you want or 

select the heading, picture, or text area the 

bookmark shall refer to. 

2. Then, press the (Shift)+(Ctrl)+(F5) keyboard 

shortcut or on the Insert tab, in the Links 

group, click the Bookmark button. 

3. In the dialog box shown on the right, enter a 

name for the bookmark and confirm it by 

clicking [_Add_]. 

You should choose a significant name and keep in 

mind that it cannot contain spaces or hyphens, but 
underscores can be used as seperators. 

 

Creating a bookmark 

Via this dialog box you can also jump to a bookmark from any place in the document: Open the 

dialog box ((Shift)+(Ctrl)+(F5) keyboard shortcut), select the bookmark in the list and click 
[GoTo]. To delete the bookmark, select it and click the [Delete] button. 

How to create a cross-reference 

1. At first, enter an explanation, e.g. "refer to page", at the respective position in the 

document. 

2. Position the cursor at the place, where you want to insert the cross-reference. In the 

example mentioned above, this is the position to the right of the space after the word 

"page". 

3. Click the Cross-reference button on the References tab, Captions group. 

The following dialog box is opened: 
 

 

Insert cross-reference 

4. Select the appropriate heading. 

5. Clicking the [Insert] button will place the corresponding page number at the cursor 
position. 

 
Enable the  Insert as hyperlink check box, when you want to use the 

cross-reference as a link. Clicking the reference (page number) will switch to 

the linked position. If the mouse pointer does not change its appearance while  
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pointing onto the reference, additionally press the (Ctrl) key. Following a 

hyperlink with or without using the (Ctrl) key is set in the Word Options, on 

the Advanced page, Editing options ane. 

Field code 

The cross-reference has been inserted as a field using the PAGEREF field name. Place the 

cursor in the field and press the (ª_)+(F9) shortcut to see the field code, e.g.: 

{ PAGEREF _Ref168552912 \h } 

The link refers to a hidden bookmark 

(_Ref168552912), which Word generated while 

creating the cross-reference. The \h switch means 

that the cross-reference was inserted also as a 
hyperlink. 

Press the (Shift)+(Ctrl)+(F5) shortcut to access 

the Bookmark dialog box. Enable the  Hidden 

bookmarks check box to see the hidden 

bookmarks. 

If you deleted the respective bookmark, the 

following message would appear for the field code: 

Error! Bookmark not defined 

However, this error message does not necessarily 

appear after deleting, but only after an update, as 

described below. 

 

Hidden bookmarks 

 

 
If you want to replace text, which contains bookmarks, with text from another 

document with the same bookmarks, you should delete the old text in the destination 

file first before inserting the new text from the source file! Otherwise, the bookmarks 

may not be available in the destination file anymore! 

Modifying cross-references 

To change the reference information, i.e. the reference type of a cross-reference, proceed as 

follows: 

1. Select the cross-reference (field), but not the corresponding explanation. 

2. Click the Insert Cross-reference button on the References tab, 

Captions group. 
 

3. In the Reference type list box, select the new item to refer to. 

 
To modify the explanation ("refer to page") of a cross-reference, edit the text within 

the document as usual. 

Updating cross-references 

Select the cross-reference to be updated or the entire document, if you want to update all cross-

references. Then use the (F9) key to update the references. The update is automatically 

performed, when the print view (print preview, pages 57) is opened, and before printing, if the 

Update fields before printing check box is activated  in Word Options on the Display 
page. 
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16.5 Inserting a hyperlink to an item in a document 

You can also jump to headings or bookmarks in the same document with the help of a hyperlink: 

1. Select the passage or the object (e.g. an image) that you want to format as a hyperlink. If, 

like in our example, the hyperlink shall display the label of the target (e.g. Preliminary 

Notes), simply place the cursor at the position in the document where the hyperlink is to be 

inserted. 

2. On the Insert tab, in the Links group, click the button shown on the right.  

3. In the Insert Hyperlink dialog box, in the Link to pane on the left, activate the Place in 

This Document button and select the place the link shall lead to in the list (e.g. the top of 

the document, one of the headings, or a bookmark), in our example Preliminary Notes. 

 

Creating a hyperlink 

 
Headings are only displayed in the list, if one of the standard heading styles has been 
applied to them. 

4. The Text to display box shows, which text will be displayed in the document. However, you 

can overwrite it. 

5. If required, you can use the [ScreenTip] button to enter an individual text, which will be 

displayed as a ScreenTip, when you point the mouse to the link. 

6. Confirm your selection by clicking [_OK_]. 

Editing and removing a hyperlink 

To edit a hyperlink, right-click it and select the Edit Hyperlink 

command from the context menu. Make the changes in the Edit 
Hyperlink dialog box and confirm them by clicking [_OK_]. 

To remove the link, click the Remove Hyperlink command from 

the context menu. 
 

Context menu (cut-out) 
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17 Master Documents and Subdocuments 

A master document is used to split comprehensive documents (e.g. books) into multiple files 

and to manage them. In master document view, you may split your document into 

subdocuments, so that Word creates multiple files, when you save your document. 
Subdocuments are thus separate Word files that you may edit without the master document. 

Benefits of master documents and subdocuments 

 Easy re-structuring of large documents. 

 The small subdocuments may be edited without loading the master document. 

 You may quickly move or jump within a master document, since not all subdocuments have 

to be opened. 

 Cross-references may be created among the subdocuments. 

 Table of contents, outline, and index are created from multiple 
documents.  

When you click the Outline button on the View tab in the Views 

command group, the following Outlining tab containing the Master 
Document group is displayed:  

 

Outlining tab showing the Master Document command group 

In the Master Document group, click the button shown on the right-hand side 
to see the commands for managing subdocuments. 

 

 

Master Document group showing the controls 

The following buttons are used to edit master documents and subdocuments: 

Button Button name Meaning 

 

Show Document 
(master document view) 

Switch to master document view. 

 

Expand Subdocuments 

(only when collapsed) 

The contents of the subdocuments is 

displayed completely. 

 

Collapse Subdocuments 
(only when expanded) 

Only the complete path to the subdocument 
file is displayed. 
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Button Button name Meaning 

 Create subdocument Subdocuments are created for the selected 
headings. 

 Insert An existing document is inserted as a 

subdocument. 

 Unlink The link to the subdocument is removed and 

the contents incorporated into the master 
document. 

 Merge Multiple separate subdocuments are 

merged to one single subdocument. 

 Split A subdocument is split into two 

subdocuments. 

 Lock Document The current subdocument (cursor position) 
is  read-only and thus cannot be modified. 

 

The following example shows that the respective headings of the 1
st

 level (Preliminary Notes, 
Lists, Borders and Shading, etc.) are always the beginning of new subdocuments: 

 

Right-hand window showing an example for a master document 

17.1 Things worth knowing 

 Based on the headings of the original document, Word can split a document into 

subdocuments. Thus a new document is created for each heading of the 1
st
 level. 

 The style sheet that is assigned to the first paragraph of the selection determines, which 

style sheet is used to create a new subdocument. 

 When the master document is saved after splitting, Word automatically uses the headings 

as file names when creating subdocuments, e.g. Lists.docx, Tables.docx, including the 

complete path to the subdocument file. 

Please note: If the heading contains a hyphen, Word uses as file name only the part before 

the hyphen. 

 In the collapsed master document view, the subdocument is opened by a mouse click while 

holding down the (Ctrl) key. 
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 You may rename subdocuments, when you access them from the master document and 

then rename them. To do this, click the Save As command from the File menu. 

 When you open the subdocument as a single document and change the file name, the 
master document will no longer be able to locate the subdocument. 

17.2 Creating master document and subdocument 

Now you create a master document and multiple subdocuments, using the following example: 

1. Open the Exercise Outline.docx file from page 151. This document contains the table of 

contents of this course document including the Fields chapter as well as the first three 

subheadings without page numbers, but including the Heading 1 and Heading 2 style 

sheets. 

2. Save the document using the name Master.docx. 

3. Switch to Outline view. 

4. Select the entire text using e.g. the (Ctrl)+(A) shortcut. 

5. On the Outlining tab, Master Document group, click the Create 

button. If this button is not available, click the Show Document button 

beforehand. The result: 

 Word places a frame around each subdocument. 

 For each subdocument, an  icon appears in the upper left-hand 
frame corner. 

 

 

 A section break is inserted after each subdocument. 

(When you want to make the section breaks visible, click the Show 

All button in the Paragraph group of the Home tab.) 
 

6. Again save the master document using the name Master.docx. The 

subdocuments are saved on the drive only now! Word has 

automatically used the headings 1 for the file names of the 

subdocuments. 

 

17.3 Master document views 

Use the switch buttons shown on the right-hand side to switch between two 

views of the master document: 

 The collapsed view, which shows only the path to the subdocument 

files as a blue link. To see the subdocument contents, click the 

Expand Subdocuments button. 

 The expanded view, which shows the complete subdocument contents. 
For collapsing, click the respective button. 

 

 

To obtain the following illustration, the Master.docx master document was copied using the 

Save As command (Master1.docx). Now the two documents are displayed side by side, with 

only the paths to the subdocument files shown in the left-hand document pane, and with the 
complete contents in Outline view shown in the right-hand document pane: 
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Two identical documents: paths to the subdocument files shown on the left-hand side, 
and contents in Outline view shown on the right-hand side 

17.4 Editing subdocuments 

Now enter text into the subdocuments and format the documents: 

Opening and closing a subdocument 

1. In the master document, select the  Subdocument icon that is located to the left of the 

Lists heading. 

2. Word opens the subdocument named Lists.docx. If you have not saved the master 

document beforehand, Document1.docx will appear! 

3. The Lists.docx subdocuments only contains headings. You may add headings or normal 

text to this document as desired. Also format these additions. 

4. Since Word inserts a section break after each subdocument, you may define different 

headers or footers for each subdocument. 

5. After completing your work, save and close the subdocument. 

6. Word automatically returns to the Master.docx master document. From this document, you 

may open another subdocument. 

Inserting a document as a subdocument 

1. Create a new document. Type the following words and assign the style sheets enclosed by 

parentheses: 

Document Templates (Heading 1 style) 

 Using document templates (Heading 2 style) 

 Creating document templates (Heading 2 style) 

 Editing document templates (Heading 2 style) 

2. Save the document using the name Document Templates.docx. 

3. Close the document, e.g. using (Ctrl)+(F4). 

4. Place the cursor at the end of the Master.docx master document. 

5. On the Outlining tab, Master Document group, select the  button. The Insert 

Subdocument Explorer window is displayed. Select the file name Document 

Templates.docx. 

6. Click [_Open_]. Word adds another subdocument to the end of the master document. The 
master document has been extended by the contents from Document Templates.docx. 
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Merging subdocuments 

Merging means that you combine multiple subdocuments into one single subdocument. In our 

example, now merge the subdocuments Tables.docx and Multi.docx to one single 

subdocument named Tables.docx. 

1. In the Master.docx master document, select the  Subdocument icon next to the Tables 

heading. The subdocument will be selected. 

2. While holding down the (Shift) key, select the Subdocument icon next to the Multi… 

heading. This subdocument will be selected as well. 

3. On the Outlining tab, Master Document group, select the  button. The  icon next 

to the Multi… heading will be deleted. Now the contents of the Multi.docx subdocument is 

found in the Tables.docx subdocument. 

4. Check this by double-clicking the  icon to open the Tables.docx subdocument. 

Splitting subdocuments 

Now split the just merged subdocument into the documents named Tables.docx and 

Multi.docx. 

1. In the master document, click the beginning of the Multi… heading. Now the cursor is 
flashing to the left of the letter M. Make sure that nothing is selected! 

2. On the Outlining tab, Master Document group, select the  button. Word places the 

Multi… heading ahead of the  Subdocument icon. 

3. Again save the master document using the name Master.docx. 

4. Open the Tables.docx and Multi.docx documents by double-clicking the respective  

icons and check their contents. 

Removing subdocuments 

There are two options for removing subdocuments: 

 The contents of the subdocument should be kept and saved in the master document. 

 The contents of the subdocument should be removed from the master document. 

Keeping the contents of the subdocument and saving them in the master document 

In our example, you want to keep the contents of the Documemt Templates.docx 

subdocument and save it in the master document: 

1. Select the  icon next to the Documemt Templates heading. The entire subdocument 

will be selected. 

2. On the Outlining tab, Master Document group, select the  button. The 

Subdocument icon is deleted and the contents is now part of the master document. 

Deleting a subdocument including its contents from the master document 

1. To delete a subdocument including its contents from the master document, select the  

icon to select, e.g. next to the Edit Tools heading. 

2. Press the (Del) key. Word deletes the subdocument including its contents from the master 

document. 

 
The subdocument is deleted only from the master document. It still exists on the hard 

disk. 
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