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20 Appendix 

20.1 Data Types 

On page 22, the data types have already been mentioned briefly and you have learned about 

them in your first table draft. The data type is used to determine, which contents a field is al-

lowed to have and how this contents is to be interpreted. When you click into the Data Type 

column, a black drop-down arrow  will appear. You can choose the data type from the list: 

 Short Text 

This data type will surely be the one that is used most. You can en-

ter virtually any characters into fields of the Text type. Typical fields 

are LastName, Street, City, or Phone. 

Please make sure that the field size of text fields is not too small or 

too large. There may be cases, in which not all data will fit into a 

field that is too small. However, fields that are too large are not use-

ful as well, because the column width in tables, reports, and forms 

will initially be adjusted to the field length. You have to search for a 

suitable trade-off. 
 

Data types 

 Long Text 

Consider the memo fields as text fields without length restriction. Whenever you want to 

store texts with significant length differences or when the 255 characters of a Short Text 

field are not sufficient, you should use this data type. 

 Number 

Numerical fields accept only characters that are used to represent numbers. Use this data 

type, when the numbers are used for calculating. In numerical fields, values like price, tax, 

discount, or invoice total are stored. 

Information such as PostalCodes or phone numbers should not be stored in number fields, 

as this information is not used for calculating. Moreover, leading zeros are eliminated in 

numerical fields, which may result in fatal errors with PostalCodes or phone numbers. 

With regard to the contents of numerical fields, the E character is an exception. It can be 

entered into numerical fields and is used as an exponent for representing very large or very 

small numbers. So, 1.00E+08 stands for the number of 100,000,000 (1 followed by 8 ze-

roes). 

 Date/Time 

The name is self-explaining. In this data type, Access manages data values from January 

1
st
, 1000, until December 31

st
, 9999. Entries are automatically checked for valid date or time 

values. 

 Currency 

The currency field is also a numerical field. However, the number is shown including the 

currency symbol specified in the Windows control panel (page 51), for example, with $ or £. 

Additionally, you can select the currency in the field properties (refer to next page) using the 

Format list box. 

 AutoNumber 

For this data type, Access automatically enters the value, and it can be used for enumerat-

ing. Depending on the setting in the field properties, the value is incremented or a random 

number is generated for a new record. The field cannot be edited. 
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 Yes/No 

For this type, only the Yes/No, On/Off, or True/False values available. 

 OLE Object 

In OLE-fields, objects originating from other applications (e.g. Excel spreadsheet, Word 

document) may be stored. Later on, you can edit the information stored in OLE fields. For 

editing, the application supporting the respective object is launched. 

 Hyperlink 

This field is used to enter a file, email, or web link. In case of a link, you can switch to a lo-

cation in another file, another application, or to a site on the World Wide Web (WWW). 

 Attachment 

As with emails, you can add various files to a record, e.g. images, sound files, documents, 

video files, etc. Thus, this type is similar to the OLE-Object type. 

 Calculated 

This data type is used to calculate values already in a table using a formula. 

 Lookup Wizard 

Users open a combo or list box and select the entry from the list. This list is filled manually 

or using the Lookup Wizard. Example: for selecting the state, all states can be provided in 

the list. 

20.2 Field Properties 

The field properties, too, have been 

introduced on page 22. When the field 

name and data type have been speci-

fied, use the mouse or the (F6) key to 

switch between the upper and lower 

parts of the design grid (page 21). In the 

lower part, you set the properties of the 

current field. Depending on the data 

type, the available selection may differ: 

 

Field Propperties 
 

Field size 

You can specify the field length between 1 and 255 only for Short Text 

fields. For the Number data type, select a value range and the number of 

decimals: 
 

Number 
 

Selection Value range Decimals 

Byte 0 to +255 None 

Integer -32,768 to +32,767 None 

Long Integer ±2 billion None 

Single very large
 1

 7 

Double huge
 2

 15 

Decimal very large
 1

 28 

1
 Precise: -3.4 * 10 38  to +3.4 * 10 38 

2
 Precise: -1.797 * 10 308  to +1.797 * 10 308 
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Only for the sake of completeness, the Replication ID setting for the Number data type is 

mentioned: This is an identifying number having a length of 16 bytes. This replication ID is 

also called GUID (Globally Unique Identifier). 

For the other types, a size is given. 

Format 

This field is used to determine how the field contents are shown on the screen and on the 

printout. Beyond a number of default formats, you can also set up your own formats. When 

you select the Currency data type, the default setting from the Windows regional settings is 

used (page 51). Additionally, you can select the currency using the Format list box. 

Input Mask 

You can define exactly how the users are allowed to enter the data into a text field. You can 

determine the input format of a phone number, for example. 

Caption 

Used as column heading, otherwise the field name will appear. 

Default Value 

Used to determine the default setting when entering new data, e.g. the city in which most of 

the customers are situated. However, this value can easily be overwritten. For the Au-

toNumber, OLE, and Attachment types, a default value cannot be specified. 

Validation Rule 

The validation rule is used to set a condition for data input. For example, with the Between 

10 And 100 rule, values below 10 or above 100 cannot be entered. 

Validation Text 

A validation message is shown on the screen when the validation rule is violated during da-

ta input. 

Required 

This Yes/No selection is used to specify whether or not the user is required to enter data 

(required field). 

Allow Zero Length 

Specifies whether two quotation marks "" are accepted for data input. This property is pro-

vided for the Short Text, Long Text and Hyperlink fields. 

Indexed 

During indexing, Access generates an internal additional table in which information is ar-

ranged in proper order. For larger amounts of data to be searched, Access uses this table 

to find a particular record quickly. In addition to that, it can be specified whether duplicates 

are allowed to occur. 

Unicode Compression 

The Unicode character set includes the characters that are most commonly used all over 

the world. This character set allows many written languages to be represented in one char-

acter table. By means of the Unicode compression, Access saves some space when the 

database file is saved on the hard disk. 

IME Mode and IME Sentence Mode 

IME (Input Method Editor) allows Chinese, Japanese, and Korean characters to be entered 

or edited. 
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Text Align 

You may also be familiar with text alignment in Word: Within a field, data is aligned left, 

centered, or aligned right. (In case you do not see this field property in the list, use the 

right-hand scroll bar to scroll down to the end.) 

20.3 Specifics of email addressing 

If you are not familiar with entering email addresses, please read the following tips. 

An Internet email address is composed of three parts: 

 

The domain name is divided into at least two elements, the web server name (owner name) and 

the top level domain (e.g. com, uk or ca). 

 
The address must be entered accurately. Even the smallest discrepancy will prevent 

the addressee from receiving the email. In this case, the message is returned to the 

sender or you will get an error message. 

For the notation of email addresses, please note the following: 

 Spaces are not used, but dots ., hyphens -, or underscores _. Particularly in case of hy-

phens or underscores, input errors may occur. 

 Language specific special characters (e.g. German umlauts ä, ö ü) are now allowed. But 

these characters must actually occur in an email address! You cannot simply write müller 

instead of mueller. Moreover, the special characters are often supported only by the latest 

applications, e.g. Office 2016! 

For the übungscomputer.de domain name, you can enter uebungscomputer.de instead, 

but only because the training material publisher, which provides these two email addresses 

for training purposes, owns these two domain names. 

 Basically, upper or lower case should be followed, but you can use lower case only, since 

the systems have become more and more user-friendly within recent years. 

 
The @ character is called commercial at or simply at sign. This character indicates 

the beginning of the so-called domain name. A domain name may comprise more 

than two parts. The top level domain found at the rightmost side (.com) has the high-

est significance. 

20.4 Start-up settings 

 

After starting the program, either the last used database is opened or the Access 

start screen appears (page 8). You can set this in the Access Options window: File 

menu,  button, Client Settings. If you want the start screen to appear, deac-

tivate the respective check box  at the lower edge of the following window: 

User name | At sign @ | Domain name

my.training@computer-workbooks.com
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Open the Access start screen or last used database 

20.5 Customizing the Quick Access Toolbar 

By default,  the Quick Access Toolbar  showing a few commands is 

placed in the upper left-hand section of the Access window. You can 

configure this bar as desired. For this configuration, nearly all Access 

commands are available. 

 

Quick access 

 

Moreover, you can place this toolbar below the 

ribbon, so it will occupy the entire width of the 

window. Thus, it will certainly provide enough 

space to accommodate your favorite icons. 

For customizing, select the right-hand button  

on the Quick Access Toolbar. In the menu, 

enable  or disable an icon. 

In this menu, only a few icons are directly ena-

bled. Use the More Commands command to 

open the Access Options window with the 

Quick Access Toolbar page: 
 

Customize the Quick Access Toolbar 

 

Select a command and then click Add or Remove 
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At first, click the arrow  in the Choose Commands 

from list and choose a category. 

To add a new command (icon) to the toolbar, select that 

command in the list on the left-hand side and then click 

the [Add] button. To remove a command from the toolbar, 

select that command in the right-hand side list and then 

click the [Remove] button. 

 
Select a category 

(cut-out) 

Use the arrows at the right-hand side to change the 

order of the icons in the bar. 

If you want to accommodate a large number of icons 

on this bar, it is best to place the bar below the rib-

bon. 

 

A special feature in Office 2016 when using tablets 

 

As already mentioned on page 14, there is an additional command on the Quick Access Toolbar 

if you use one of the Office programs on a tablet or if some other touch-sensitive screen is con-

nected. 

By clicking this symbol, you switch between touch and mouse 

mode to improve the ribbon for the corresponding input. Touch 

mode offers a little more space between the commands on the 

ribbon. 

As far as the commands and groups on the ribbon are con-

cerned, apart from a few exceptions, there is no difference be-

tween Office 2016 on a PC, a laptop or a tablet.   

 

Menu of the Touch/ 
Mouse Mode icon 

20.6 Setting the status bar 

At the bottom of the Access program window, the status bar is found, which provides some 

information and setting options: 

 

Status bar in Print preview 

You can set the contents of the status bar as 

desired: 

Right-click the status bar, which will open the 

menu shown on the right-hand side. Selecting 

one row will enable  or disable an option. 

Click outside the configuration menu to close the 

menu. 
 

Set the status bar 
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15 Forms 

Forms are a very powerful Access tool for entering and maintaining data as well as for automat-

ing procedures. 

The major difference from the table representation is that the form mostly shows only one single 

record. This is not necessarily always the case. You can also create forms using the table rep-

resentation. In contrast to the table representation, which is used to display a large amount of 

information in a very compressed manner, information can be provided in a significantly better 

structured way, when a single record is displayed. 

Typically information that belongs together is presented next to each other in the form. Moreo-

ver, individual fields can be identified more easily by their preceding labels. 

15.1 Creating an AutoForm 

An AutoForm is a ready-to-use form – as convenient as it gets: 

1. Close all object windows. Only the Training database window is not closed. 

2. Open the first Suppliers table that was created on page 22 by double-clicking the name in 

the navigation pane. 

3. On the Create tab, click the Form button (Forms group). Access now creates 

a very useful form of the opened table and opens it in the so-called Layout 

view:  

 

Form in Layout view 

In the title bar, you see the button for the context tools (Form Layout Tools) and below, the 

Design, Arrange, and Format tabs are located on the ribbon. 
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15.2 Form views 

Access provides various view options for forms: 

 Form view 

 Layout view 

 Design view. 

 Print preview (using the File menu).  

View change button 

Form view 

Form view is used to enter the data. A well-designed form can be more appropriate for entering 

data than the datasheet view of the table. 

Layout view 

In Layout view, you can continue designing the form, but you already see records with original 

data. 

Design view 

Design view is used to create and design your form as desired. When designing the form, the 

goal is to facilitate data entry. To achieve this, a number of tools is available. In Design view, 

you do not see any data, but only the so-called controls including the field names. 

Print preview 

Print preview additionally shows the form as it will be printed including the records. This view is 

opened using the Print page of the File menu (refer to page 40). 

Save the form using the name Suppliers Form1. Then switch to Form view: 

 On the Home or Design (Form Layout Tools) tabs, click the upper part of the View 

change button. Clicking the lower part  opens an additional submenu. Select the Form 

View command. 

 Or select Form View from the context menu. 

 Or click the Form View icon at the bottom right-hand corner of the status bar . 

Form view is used to enter new data or to modify or delete existing data. To navigate between 

the fields and records, most of the commands are available as listed for Datasheet view from 

page 27 on. However, the significant difference from the table is that Form view shows only one 

record on the screen page. 

Also, the Sorting and Filtering commands can be used in Form view without any restrictions. 

15.3 Modifying the appearance of the form 

The appearance of the form can be changed in Layout view and in Design view. Now switch to 

Layout view. 

 

Design tab (Form Layout Tools) 
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The Design, Arrange, and Format tabs (Form 

Layout Tools) provide a number of options for 

adjusting the layout of the form as desired. Also, 

predefined formats are provided in the Themes 

group (Design tab). 

When you point to a theme in the gallery, the form 

is immediately displayed using the new formatting 

(live preview). Select the name to choose a theme. 

Use the remaining buttons (Colors, Fonts) of the 

Themes group to modify the current theme. The 

command for saving the modifications is located at 

the bottom of the Themes gallery. The modifications 

are saved as a user-defined Office Theme using the 

*.thmx (themes) file extension and can be used e.g. 

in Word or Excel as well. 

 

On the Design tab 

 

Themes gallery 

Selecting controls 

The themes are used to modify the appearance of the entire form as desired. If you want 

to modify only individual items, so-called controls, the respective item must be selected 

by clicking it. A selected item is identified by its thick, colored border.  

The data including the preceding field names are displayed in a table. To select several table 

cells, hold the (Shift) key while selecting with the mouse. 

When individual parts of the table are select, the  handle is shown in the upper left-hand cor-

ner of the table. You may already know this table handle from the text processing program 

Word. Click the table handle to select the entire table or use the (Ctrl)+(A) shortcut to select 

the entire form. 

Modifying individual controls 

To modify the Font, Font Size, or Font Color for the se-

lected controls, select the respective buttons of the Font 

group on the Format tab (Form Layout Tools). 

Icons are also available for Alignment and Background 

Color. If you, for example, want to right-justify the field 

names preceding the data boxes, first select the cell of the 

Number field name. While holding down the (Shift) key, 

select the cells below up to and including Telephone. Click 

the Align Right  icon. 

 

On the Format tab  

(Form Layout Tools) 

 

Right-aligned field names 

Moving the table using the mouse 

You can easily move the entire table to another position using the mouse: 

The table handle  has already been discussed. Place the mouse on this handle. 

You'll see an additional four-headed arrow at the mouse pointer. With the left mouse 

button held down, drag the table to the new position. 
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Properties 

Access uses a list to display the properties of the currently selected control. To open this Prop-

erty Sheet task pane, select: 

 the Property Sheet button (Form Layout Tools) in the Tools 

group of the Design tab, or 

 press the (Alt)+(Enter) shortcut, or 

 right mouse button (context menu): Properties. 

 

On the Design tab  
(Form Layout Tools) 

 

Form including the Property Sheet task pane 

In the task pane, you can directly modify many properties by editing the existing value or by 

selecting a value from a list . 

15.4 Inserting a title 

A heading is to be positioned at the upper border of the form: 

1. On the Design tab (Form Layout Tools) in the Header/Footer group, select the  

button. A large frame with selected text is inserted. 

2. Type Suppliers List. 

3. Switch to Form View and check the result: 

 

 Form including title and minimized ribbon (also refer to page 12) 
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4. If you want to modify the font of the title, return to Layout view. 

5. Use the mouse to select the title and modify the font using the Text Formatting group on 
the Home tab. 

15.5 Entering new records 

As is the case with the datasheet view of a table or query, you can use the form to enter new 

records. Select one of the following commands to get a new, empty form page. 

 New icon  in the Records group of the Home tab 

 New Record  icon on the record toolbar at the bottom 

 (Ctrl)+(+) shortcut. 

As in the table view, complete the field entry by pressing the (Enter) key or (Tab) keys. When 

you press one of the two keys in the last field of the last record, a new, empty form page is 

opened. For moving within the form, most of the commands mentioned on page 27 apply as 

well. 

15.6 Exercise 

1. Save the form again using the name Suppliers Form2. 

2. Design a form also for the Suppliers2 table and save the new form using a name of your 

choice. 
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